Debian更新问题

在国外Linux的服务器很常见,由于咱们长期在国内享受5元一张的WINOS习惯了,所以每月要花几十块的版权费咱们舍不得……

之前摸索centos,好不容易能勉强的跑起来自己的服务了,但是nnd人算不如天算啊,centos用不鸟了,要用大便了,据人说大便好哇,国外半壁江山啊,yum变成 apt-get 而已,好吧,心急火燎的做上debian就apt-get update 擦,傻眼了,源有问题,你不是坑爹吗,幸亏咱还能修改一下……

vi /etc/apt/sources.list

都干掉,换成

deb http://ftp.debian.org/debian lenny main contrib non-free
deb http://security.debian.org/debian-security lenny/updates main contrib non-free
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

终于不坑爹了。看来需要在抱着debian的大腿了!

debian apt-get 安装PHP环境

反反复复蒸腾大便,重做系统无数,估计IDC杀我的心都有了。 这里弄个简单的流程给大家吧,LNAMP 首先替换该死的源…… vi /etc/apt/sources.list 然后替换成下列

deb http://ftp.us.debian.org/debian lenny main contrib non-free
deb http://ftp.debian.org/debian lenny main contrib non-free
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

升级 apt-get update然后你需要什么就安装什么吧

apt-get install mysql-server-5.1
apt-get install nginx apache2 php5 php5-common php5-cgi php5-mysql php5-curl php5-gd php5-idn php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-mhash php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl

您缺啥就安装啥吧,哎~~

debian 下依赖安装

由于ubuntu/debian软件库中有时候不同的库更新速度不一致,apt-get往往不能如人意
这时候使用”aptitude” 能帮助我们解决不少问题
使用这个工具,当某个库依赖的库与当前版本不一致时,aptitude 会尝试降级当前这个库的版本,同时解决降级这个库对其它软件的依赖性的影响, 最终成功安装apt-get 没法安装的软件
如:#aptitude install rpm

debian下部署java环境(Nginx+tomcat+mysql)

光听说Debian很吊的样子,经过这两天不懈的reload os (对不起IDC)
终于发现部署jsp环境比centos 还速度(不算起我之前写的一键shell)。
首先更新源到最新,debian这点很猛就是源更新很快,虽然稳定性不一定能保证,但是apt-get比yum还生猛,
呃,真滴猛男,只要会apt-get 就能勇闯江湖了………… (扯淡了)
首先源我已经更新了,那么来安装 LNTM环境把
apt-get install nginx
apt-get install mysql-server
apt-get install sun-java6-jdk
安装mysql的时候需要你输入password。
然后启动各项就行了。
invoke-rc.d nginx
invoke-rc.d mysql
./start.sh
然后“彪悍”的内存占用…………